[Cluster-devel] [PATCH v2 5/6] iov_iter: Introduce ITER_FLAG_FAST_ONLY flag
viro at zeniv.linux.org.uk
Mon Jul 19 20:17:42 UTC 2021
On Mon, Jul 19, 2021 at 12:29:35PM -0700, Linus Torvalds wrote:
> On Sun, Jul 18, 2021 at 3:40 PM Andreas Gruenbacher <agruenba at redhat.com> wrote:
> > Introduce a new ITER_FLAG_FAST_ONLY flag
> I think the code is fine, but I think it might be best to call this
> "ITER_FLAG_NOIO" or something like that.
> The "FAST_ONLY" name makes sense in the context of
> "get_user_pages_fast()" where we have that "fast" naming (and the long
> history too). But I don't think it makes much sense as a name in the
> context of iov_iter.
This code has never been tested with current lib/iov_iter.c as it is
in mainline. Or had been in -next during the last cycle. It won't
apply at all.
Sure, I can try to port that series over to the current mainline, but
I'd rather see that done (and tested) by the series author...
More information about the Cluster-devel