Stephen John Smoogen
smooge at gmail.com
Tue Jul 10 17:09:59 UTC 2007
On 7/10/07, Thorsten Leemhuis <fedora at leemhuis.info> wrote:
> On 10.07.2007 17:59, Patrice Dumas wrote:
> > On Tue, Jul 10, 2007 at 08:17:46AM -0500, Rex Dieter wrote:
> >> So, I was leaning toward following rpmforge's fftw/fftw3 naming scheme,
> > Although naming fftw3 the newer version seems acceptable to me,
> > especially if upstream breaks api now and then, naming the old version
> > fftw seems wrong to me. [...]
> >From looking at it at this point of time I tend to agree.
> Normally I'd say that the latest version of "foo" should always be foo
> as long as upstream calls it foo (IOW: fftw3 in this case is confusing
> as upstream calls it fftw). If we ship foo (major-1) I'd expect we'd
> call it compat-foo or foo(major-1) (e.f. fftw2 in this case). Calling
> the older one simply foo (fftw) would IMHO be to confusing, as a lot of
> people that simply want to install "foo" will expect the latest version
> when they run "yum install foo".
Isnt there something about dropping the compat naming scheme and going
to something else? Or am I confused about a different email thread.
Here are my best attempts at Solomon
The first question I would ask is what are your customers wanting?
What packages need a Fast Fourier Transform and what do a majority of
customers running on EL want it to be? If the scientific community is
using lots of fftw2 versus fftw3 then that might be a good reason to
keep to older name schemes.
The second question is what is the new packaging name scheme? If the
name scheme is still compat-<package>-<major-minor> I would go with
that.. if it isnt then I would go with something like: fftw_22 fftw_3x
as the name schemes
Third I would go for an open and documented reasoning document from
both forge and you on why the names are different and how a user would
be able to deal with this issue.
Stephen J Smoogen. -- CSIRT/Linux System Administrator
How far that little candle throws his beams! So shines a good deed
in a naughty world. = Shakespeare. "The Merchant of Venice"
More information about the epel-devel-list