[et-mgmt-tools] Connecting to a remote libvirtd host using virt-manger

Cole Robinson crobinso at redhat.com
Tue Dec 2 21:26:12 UTC 2008

Jon Smith wrote:
> On Mon, Dec 1, 2008 at 8:43 AM, Cole Robinson <crobinso at redhat.com> wrote:
>> Jon Smith wrote:
>>> virt-manager and libvirtd both functioning locally.  I tried to use
>>> virt-manager to access the same libvirtd host remotely but I'm having
>>> some trouble.
>>> I'm using qemu+ssh to connect to the remote host, but when I do,
>>> virt-manager turns gray and becomes unresponsive, eventually the part
>>> of the window showing the hosts goes blank.  If I stop libvirtd on the
>>> remote host, virt-manager refreshes itself and shows the libvirtd host
>>> as connected, and even lists all the domains available.  I'm also able
>>> to connect using virsh and that works fine.
>>> I can repeat this process over and over again, even after rebooting
>>> the hosts involved.  I've also run libvirtd with the --verbose flag
>>> and can send the output (~80K) if that would help.
>> What distro are you using? What virt-manager version? Distro package or
>> compiled from source?
>> How are you invoking virt-manager? Can you try running 'virt-manager
>> --no-fork' from the command line, trying to connect to the remote host,
>> and seeing if a password prompt pops up in the terminal?
>> Thanks,
>> Cole
> Server is CentOS 5.2, client is fedora 9.  Virt-manager version is
> 0.5.4 binary RPM from the Fedora repo. The server was Fedora 9 but I
> installed CentOS 5.2 on it today and it's using the Xen kernel now and
> having the same trouble.  Again, locally, virt-manager works
> fantastically, but when I try to connect remotely it gives me trouble.
>  I don't know how it could possibly matter, but I'm connecting back to
> another location using vpnc and then opening virt-manager, so I've got
> maybe 150ms latency to the libvirtd host.
> I've been launching virt-manager from Applications -> System Tools ->
> Virtual Machine Manager.  Also I've launched it a few times with
> something similar to: $virt-manager -c xen+ssh://
> Now I've also tried: $virt-manager --no-fork -c
> xen+ssh:// (no password prompt by the way). It seems
> to be logging in because, like I said, if I stop libvirtd, I get a
> list of the available guests on the libvirtd server.  And actually
> once I connect if I wait 15 or 20 minutes it will return a list.  It
> will just freeze up intermittently and it's never responsive to input.
>  If I try to click on a guest to select it, it will take 2 or 3
> minutes before the selection takes effect and the item is highlighted.

Sounds like virt-manager is connecting fine, but the communication with
the remote libvirtd is so slow virt-manager is frozen solid waiting for
all the polling calls to return.

Can you try 'virsh --connect your_remote_uri' from the host you are
running virt-manager, and see if there is a large delay when connection,
listing domains, etc. If there is though, I'm not sure what could be
causing the delays.

- Cole

More information about the et-mgmt-tools mailing list