[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] Xen, Windows 2003 and APIC



Gary Pennington wrote:
> Hi,
>
> I've been investigating networking performance for Windows 2003 guests
> on a Solaris dom0 and I've uncovered a couple of things which I don't 
> really understand and I'm looking for some explanations.
>
> This first question is really directed at virtinst developers...
>
> Windows guests have different ACPI and APIC settings depending on which
> variant of Windows is to be installed:
>
> variant: unspecified	-> ACPI: true, APIC: true
> variant: winxp		-> ACPI: false, APIC: false
> variant: win2k		-> ACPI: false, APIC: false
> variant: win2k3		-> ACPI: true, APIC: true
> variant: vista		-> ACPI: true, APIC: true
>
> The question is: why don't all Windows variants have the same ACPI and APIC
> settings?
>
>   

One of the motivations for the ACPI = False, was that when installing
those versions of windows with ACPI enabled, the installer required
manual intervention. The user had to hit F5 or something in a small
time frame and specify a non-default HAL, otherwise the install would
just freeze. Well, that's what I recall anyways. I can't seem to find
a bz about the issue, and the hg history isn't much help.

I have no idea if APIC played a part in the above issue, or why it's
off for winxp or win2000.

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]