[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] Virt-Manager not connecting qemu:///system

Cole Robinson schrieb:
Eric Duda wrote:
Daniel P. Berrange schrieb:
On Fri, Sep 26, 2008 at 11:38:40AM +0200, Eric Duda wrote:
Hi all,

I yesterday installed virt-manager 0.6.0 and have now problems connecting to libvirtd,
I run Ubuntu Hardy, and  backported libvirt 0.4.2.
With the 0.6.0 release, virt-manager shows only connecting and I got the following error message in virt-manager.log:
virt-manager 0.6.0 requires libvirt >= 0.4.5, hence why you get these
python errors with 0.4.2.


This is a little bit crazy.
I also tried it yesterday with libvirt 0.4.6 from source and build a deb, but got the same error.
I installed now again the deb I yesterday build, and it works.

It's easy to forget, but anytime you update libvirt you will
need to restart libvirtd. Sounds like that could be the problem.

- Cole

I did a second install on a different host, and my yesterday problem was, that I removed the libvirt-bin, libvirt0 and because of dependencies python-libvirt before installing the new packages. But without the python-libvirt package I get "ImportError: No module named libvirt" error.

After my first mail I did only remove libvirt-bin, and it worked.
I have now python-libvirt from Intrepid installed, and it works on both boxes.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]