[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [et-mgmt-tools] libvirt/vit-manager with custom kernel



Sukadev Bhattiprolu wrote:
> 
> I am running virt-manager and kvm on a T61p laptop running Ubuntu 8.04.
> 
> I am able to create and run Fedora10 kvm image fine from within the
> virt-manager (Attached 'working.xml' file shows the dumpxml output
> of this guest image).
> 
> I am trying to run this same image with a custom 2.6.28 kernel. I tried
> adding following lines to the <os> section of the 'working.xml' file.
> 
> 8a9,10
>>     <kernel>/home/suka/vm/kernels/vmlinuz-2.6.28</kernel>
>>     <cmdline>"ro root=UUID=fa22e974-699a-4c9a-9e7f-62c138642239 debug"</cmdline>
> 
> The guest seems to start up when I when run:
> 
> 	$ sudo virsh create new.xml
> 
> and I can see kvm running as follows:
> 
> 	$  ps -f |grep kvm
> 	root      3040  6035 99 17:02 ?        00:08:21 /usr/bin/kvm -M pc -m 512 -smp 2 -monitor pty -kernel /home/linux/vm/kernels/vmlinuz-2.6.28 -append "ro root=UUID=fa22e974-699a-4c9a-9e7f-62c138642239 debug" -drive file=/home/linux/vm/fc10.img,if=ide,boot=on -net nic,macaddr=00:16:3e:0d:ca:1c,vlan=0 -net tap,fd=12,script=,vlan=0 -usb -vnc 127.0.0.1:0
> 
> But when I connect to console:
> 
> 	$ vncviewer 127.0.0.1:0
> 
> I just see "serial0 console" in the vncviewer and nothing happens.
> 
> I believe the 'vmlinuz-2.6.28' kernel is fine, since I can boot it with
> following kvm command line
> 
> 	$ /usr/bin/kvm \
> 		-kernel /home/linux/vm/kernels/vmlinuz-2.6.28 -smp 8  -m 1024 \
> 		-append "debug ro console=ttyS0 root=/dev/sda1"		\
> 		-hda /home/linux/vm/fc10.img -no-reboot -vnc :9	\
> 		-redir tcp:2209::22 -serial telnet::2009,server
> 
> But the same kernel in the virt-manager/libvirt just hangs. virt-manager
> shows that the 'guest' is using about 50% CPU and memory but nothing
> really seems to be happening.
> 
> I checked ~/.virt-manager/*log, /var/log/messages and dmesg on the host (T61p).
> Only message I found, repeated several times was in dmesg:
> 
> 	'vcpu not ready for apic_round_robin'
> 
> Are there other log files I should check or is there a way to have kvm
> print out more useful info on what is happening ?
> 

I think you listed about as much info as there is to gather. If the
guest is spinning the cpu like that, my guess is something is wrong with
the qemu invocation.

The libvirt generated command line and the one you are using manually
have quite a few differences in them. I would run the libvirt generated
command manually, verify that it fails, and start working your way back
towards the original command line option by option to see if you can
determine the culprit. Start first with the kernel arguments, then maybe
mem + smp values, etc. etc.

Thanks,
Cole


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]