[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[et-mgmt-tools] Can't create new machines using virt-image - missing something obvious, likely user error...


Thanks to the help from before and documentation all over the place, I'm
now using libvirt, KVM, virt-install and vmbuilder from Ubuntu, everything
is going really well (so thanks for that).

The next thing I've been trying is getting Windows XP virtualised. I have
managed now and have a virtual machine defined in libvirt, that's all fine.

So now what I'd like to do is prepare an XML file and a hard drive image
that I can send on DVD to the other offices at work for them to install
using virt-image.

Here's my XML for virt-image:

    <boot type="hvm">
          <acpi state="off"/>
        <loader dev="hd"/>
      <drive disk="xpvmimage.raw" format="raw"/>
    <disk file="root.hdd" use="system" format="raw"/>

and I'm trying to get that working using:

virt-image --vnc mytestimage.xml

When I run that, I get "Error parsing 'mytestimage.xml': Disk entry for
'xpvmimage.raw' not found"

My image is actually in qcow format (now qcow2). I've tried using qcow and
raw with no luck. The xpvmimage.raw is in the same directory I'm running
the command from and the same place as the xml so I don't think it's just
that it can't find the file.

I'm fairly sure that I'm missing some vital information here... Hopefully
someone on the list can point out where I'm going wrong. I'm pretty sure
this isn't a fault with the code, I'm just doing it wrong or not
understanding. Is there a special format for these hard drive images I
should be using? I was thinking I'd just copy the .qcow (or convert it to
.raw) and that would be alright.

Thanks for your help.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]