[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext3 mount problems

Abheek writes:
> After a rather severe hard boot, my machine refuses to mount homes, which
> are on an ext3 partition. Here is the error i get while mounting...
> # mount /dev/sdc1
> EXT3-fs: invalid journal inode
> EXT3-fs: get root inode failed
> mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
> 	or too many mounted filesystems
> However I am able to mount it as ext2 and continue. I am using ext3-0.0.6b
> on kernel 2.2.19. The drive is a SCSI on a AIC7xxx controller.
> Any fast way to get around this (rebuilding the journal perhaps?) or is it
> something more involved. I tried passing -o journal=<inode> and mounting
> again using a new journal file, but that gave the same error.

You need to specify "-o noload, journal=<inode>" for it to re-initialize
the journal.  Make sure that <inode> _is_ actually the journal inode.

However, e2fsck _should_ detect a bad journal and clean it up.  I assume
you have tried running e2fsck on the filesystem?  Try looking at the
output of "dumpe2fs -h <device>" to ensure that the journal is still
set up correctly.  In rare cases, if the journal (or superblock)
is totally corrupt, the journal will be deleted and you will be back
with an ext2 filesystem.  You need to run (a very recent version of)
"tune2fs -j <device>" to re-create the journal.

Cheers, Andreas
Andreas Dilger  \ "If a man ate a pound of pasta and a pound of antipasto,
                 \  would they cancel out, leaving him still hungry?"
http://www-mddsp.enel.ucalgary.ca/People/adilger/               -- Dogbert

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]