[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ouch, here's an odd one.

On Mon, 5 Feb 2001, Stephen C. Tweedie wrote:

> On Fri, Feb 02, 2001 at 01:06:58PM -0800, Jay Weber wrote:
> >
> > Upon reboot after the lockup though my CVS is a bit 'odd'.
> Is this reproducible?  Were there any kernel logs anywhere?  Have you
> ever seen this without LVM and/or loopback devices in the picture?

Well, simply doing the following (without a forced sync call) leads to
either the lack of copied file after reboot, or a bogus copy of the file,
when done on ext3.  Forcing a sync prior to reboot seems to keep the data

cp /etc/fstab /
reboot -nf

cat /etc/fstab after reboot (if it exists), I'm getting NULL data or
various random "stuff" in it.

Tried it under ext2 also, and in it's case either the file is not present
or after fsck the data in file was proper.

This was done with 2.2.19pre8 or so and ext3-0.0.5e.  It's also apparent
in our VA 2.2.18pre11 kernel.  (I tried vanilla to make sure it's not
something in our kernel).  I've tried it on a battery backed up
raidcontroller device as well as my ide based laptop, to see if any
differences there also.

Not sure what else I should add. :)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]