[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [e2fsprogs-1.24] "fsck -A -a" fails on reboot

On Fri, Sep 07, 2001 at 01:24:41AM +0200, Michael Renner wrote:
> btw. does anybody know why the mtab sanity checks were removed from
> e2fsck?

They were removed because that checking should be done in
lib/ext2fs/ismounted.c, and in every testing situation I've been able
to come up with, it works just fine for me.  

*Please*, pull down the sources for e2fsprogs, and after building it,
cd to lib/ext2fs and build tst_ismounted using make "make
tst_ismounted".  Then with your root filesystem mounted read-only, and
/proc unmounted, or whatever else your system configuration might be,
run "tst_ismounted /dev/hda1", where /dev/hda1 should be replaced by
your root filesystem.  It should report something like this:

Device /dev/hda1 reports flags 07
	/dev/hda1 is mounted.
	/dev/hda1 is read-only.
	/dev/hda1 is the root filesystem.

If it doesn't say this, single step tst_ismounted and send me the gdb

I've tried this with devfs.  I've tried this with /proc unmounted.
I've tried this with /etc/mtab as a symlink to /proc/mounts (and /proc
mounted).  It works in every single wierd-shit, non-standard situation
I've been able to devise.  Clearly Patrick Volkerding is more clever
than I at thinking up weird-shit, non-standard configurations, so I'm
going to need some help from people who are reporting problems.  

All I can say is that I can't produce it on any of my production
boxes, and on my testing boxes, I've tried lots of different
configurations, and so far I haven't been able to replicate the

						- Ted

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]