[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ext3 crash after RedHat 7.2 installation

Hi everyone,
	I've been running Redhat 7.2 (new install) for about 2 weeks now
without any problems, but today I was not so lucky.
My system hung while I was trying to configure the kernel-source RPM using

After rebooting the system, it seems that my whole ext3 file system is
I get the message:

Mounting root filesystem
EXT3-fs: ide0(3,3):couldn't mount because of unsupported optional features
(200 0200).
mount: error 22 mounting ext3
pivotroot: pivot_root(/sysroot, /sysroot/initrd_ failed: 2
Freeing unused kernel memory: 220k freed
Kernel panic: No init found. Try passing init= option to kernel

(system hangs.......)

At this point I decided to boot from the CDROM and go into "linux rescue"
The rescue mode tried to mount the RedHat Linux installation to
/mnt/sysimage but this failed, so it kicked me into a command shell.

Being a newbie kernel hacker, I ran the following utilities that I was
familiar with most.
Please see below for their respective outputs:

fdisks -l =>
	shows that my root partition(/) still resides in /dev/hda3
	/dev/hda1 is my Linux boot
	/dev/hda2 is my Linux swap

mke2fs /dev/hda3 =>
mkefs 1.23, 15, Aug-2001 for EXT2 FS 0.5b, 95/08/09
Filesystem label =
OS type: Linux
Block size = 4096 (log = 2)
4980736 inodes, 9958291 blocks
497914 blocks (5.00%) reserved for the super user
First data block=0
304 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
	32768, 98304, etc.................. 7962624

Writing inode tables: done
Writing superblocks and filesystem accounting information: done
This filesystem will be automatically checked every 31 mounts or 180 days,
whichever comes first. Use tune2fs -c or -i to override.

fsck.ext3 -v /dev/hda3
e2fsck 1.23, 15-Aug-2001 for EXT2 FS 0.5b, 95/08/09
/dev/hda3: clean, 11/4980736 files, 156309/9958291 blocks

I rebooted the system and got the same message:
Kernel panic: No init found. Try passing init= option to kernel

This was the extent of my file system knowledge.
Any help you can provide would be great cause it would save me hours/days of


thank you,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]