[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: puzzling error message

On Mon, 2002-01-07 at 20:50, Andreas Dilger wrote:
> On Jan 06, 2002  22:43 +0000, Matthew Dickinson wrote:
> > whilst updatedb was running, i had these messages appear...
> > 
> > Jan  6 22:18:42 jaguar kernel: EXT3-fs error (device ide0(3,3)): 
> > ext3_readdir: bad entry in directory #147553: rec_len %% 4 != 0 - 
> > offset=0, inode=1651076143, rec_len=19527, name_len=85
> Hmm, this looks like data being written into a directory block:
> 1651076143 = 0x62696c2f = "/lib"
> 19527 = 0x4c47 = GL
> 85 = 0x55 = U

This may be similar to the problem I had a while ago where I ended
up with directories that were junk because they referred to files
of weird sizes or daft locations and lots of them got thrown into

I actually re-installed RedHat 7.2 on the laptop I had hassle with 
and have been running it with ext2 (sorry ;-).  

Over Christmas I had some weird problems that I tracked down to some
libraries in /usr/lib (libglib and other important ones!) that had
become corrupted; first I noticed that the directory entries were wrong
and then after fsck fixed these errors it also seemed that the files 
themselves were affected.

I ran rpm again to force these libraries to be re-installed and things
have worked okay, as far as I can tell, ever since.

I did have a power failure on the laptop (battery ran down) but I 
immediately re-booted and fsck fixed the problems it found.  I'd since
ran the machine with no apparent problems.

The only thing I did between it booting fine (and running stuff that
depended on these libraries) after the power glitch was run a heavy
compile over night.

What is weird is that in this recent case, and the one before, the
corruption has been in partitions that I would have thought wouldn't
be written too, e.g. I could understand if, while writing to /home
I got trashed data, but I didn't expect /usr to be corrupted simply
by reading it?  Unless the head in the HDD had crashed but I would
have expected the Win2000 partion to be affected as well and it 
doesn't seem upset at the moment.

Sorry, I've hijacked this thread a bit; to bring it back to the 
original posters problems: if these turn out to be due to hard drive
corruption, which is what Stephen suggested the glitches I saw were
due to, it would be interesting to know how and why laptop HDDs seem
to suffer from these problems.

I've seen symptoms on desktops as described in the signal 11 FAQ but 
these have been due to memory or processor problems, apparently 
though any hardware may be the cause of glitches that crash 
programs when put under stress maybe there should be a special section
in the FAQ for laptop HDD if this is a similar sort of thing?   

Andy Bianchi
Technical Consultant
Xinetica Ltd http://www.xinetica.com
Tel: +44 (0)1925 759838
Mob: 07866 381166

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]