[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OOPS: kernel BUG at transaction.c:1857 on 2.4.17 while rm'ing 700mb file on ext3 partition.

Stephen C. Tweedie wrote:
On Thu, Jan 24, 2002 at 04:54:34PM +0100, frode wrote:
I got the following error while rm'ing a 700mb file from an ext3 partition:
Assertion failure in journal_unmap_buffer() at transaction.c:1857:
"transaction == journal->j_running_transaction"
Hmm --- this is not one I think I've ever seen before.

[oops trace snipped]

NVRM: loading NVIDIA NVdriver Kernel Module 1.0.2313 Tue Nov 27 12:01:24 PST 2001
with this driver loaded we really can't make any guarantees about your
system stability at all.  If you manage to eliminate other oopses and
still get the ext3 one, even without the NVidia driver loaded, then
there would be a much better change of debugging things, but right now
it sounds like a hardware problem.

OK, I rebooted and gzip'ed the NVdriver in /lib/modules... to make sure the module doesn't load (lsmod now says my kernel isn't tainted). I'll try using the plain 'nv' driver shipped with XFree instead for a while. I tried making another 700mb iso image and fool around with it (loopback mount it, umount it, then rm it) but couldn't trigger anything - but I just spent five minutes trying.

As I mentioned I have had quite a few oopses lately, most of them regarding paging etc. (but I'm no kernel expert). See for example

I'm running linux on an old p100 as well but don't see any problems, so as you say I suspected a hardware problem. I ran MemTest86 for about half an hour without any errors (but of course there's plenty of other things that may be wrong).

Do you have any suggestions on other ways I could try to put my hardware stability on trial, or try to reproduce the bug (to see if it occurs on a non-tainted kernel)?

- Frode

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]