[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Ext3 problems possibly plauging me


My box has been running flawlessly for months now, but in the last 2 days
hasn't stayed up for more than 5 minutes.
All this seemed to have started after I did a very very bad thing......
I ran the EXT2 to EXT3 conversion on my root filesystem.
I used the "tune2fs -j /dev/sda1" to do the deed.  After it completed
the machine ran fine (the machine was up and serving when I enabled ext3,
and I did not reboot.   At least it seemed to run fine untill about 2 hours
later when it crashed.
When I tried to boot FSCK couldn't complete.  It would hang, crash, or just refuse.
I then booted off a RH7.2 isntall CD ("rescue linux") with which I used debugfs to remove the journal and I then fscked it.  The first pass with FSCK reported something about finding a journal block on the EXT2 filesystem and do I want to clear it?  I figured this was probly a big part of my problem, so I cleared it and then completely refscked the disk.  I mounted the filesystem to make sure /etc/fstab wouldn't mount the filesystem as ext3.
Yet I'm still having the same problem.

At this point I'm not sure what to do.  I'm fighting with either a) the ext2-ext3 conversion which killed me, or b) a componant has failed and the timing has really really bad.

I've got 3 kernels avalible on the system, 2.5.1, 2.4.15, and 2.4.17-mjc.
All 3 kernels have ext3 in 'em.

Any ideas AT ALL would be very very very helpful.

Thank You.

brockwood homestead-inc com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]