[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Ext3 problems possibly plauging me

On Jan 28, 2002  15:00 -0800, Ben  Rockwood wrote:
> All this seemed to have started after I did a very very bad thing......
> I ran the EXT2 to EXT3 conversion on my root filesystem.
> I used the "tune2fs -j /dev/sda1" to do the deed.  After it completed
> the machine ran fine (the machine was up and serving when I enabled ext3,
> and I did not reboot.  At least it seemed to run fine untill about 2
> hours later when it crashed.

Well, this is the right thing to do if you want to convert the fs to ext3.
Note that it wouldn't have even started to use the ext3 code until after
the initial reboot, so it is unlikely that this would have been the cause
of the initial crash.  The only thing the above command will do is to
create a regular file in your filesystem, called .journal, mark it
immutable (so you don't delete or overwrite it by accident), and then
store the inode number into the superblock (which should also be safe,
since it doesn't touch anything else in the superblock, except a flag
which says "this fs has a journal").

> My box has been running flawlessly for months now, but in the last 2 days
> hasn't stayed up for more than 5 minutes.
> When I tried to boot FSCK couldn't complete.  It would hang, crash, or
> just refuse.

That is a very unusual situation, because e2fsck will rarely crash, and it
should be impossible for it to hang the system.  Do you get any errors on
the screen related to IDE/irq/hda failures?

> I then booted off a RH7.2 isntall CD ("rescue linux") with which I used
> debugfs to remove the journal and I then fscked it.  The first pass with
> FSCK reported something about finding a journal block on the EXT2 filesystem
> and do I want to clear it?

That would be normal if you deleted the "has_journal" flag with debugfs.

> I figured this was probly a big part of my problem, so I cleared it and
> then completely refscked the disk.  I mounted the filesystem to make sure
> /etc/fstab wouldn't mount the filesystem as ext3.
> Yet I'm still having the same problem.

Sounds like it is hardware (disk/ram/cpu).  Did you make any other changes
to your system since the last time it was rebooted (e.g. new kernel,
hdparm settings, BIOS changes, etc)?

> At this point I'm not sure what to do.  I'm fighting with either
> a) the ext2-ext3 conversion which killed me, or
> b) a componant has failed and the timing has really really bad.

Well, as I mentioned above, ext2->ext3 conversion is basically just making
a 32 MB regular file, and then when the fs is next mounted as ext3 it is
used as the journal.  There is no other "conversion" to be done.  After
running e2fsck, there should not be any lingering damage to the filesystem
itself even in the unlikely case there was a problem (you might get data
errors in your files if that happened, and e2fsck couldn't detect/fix that)
but that wouldn't cause your system to hang or crash.

> I've got 3 kernels avalible on the system, 2.5.1, 2.4.15, and 2.4.17-mjc.
> All 3 kernels have ext3 in 'em.

Which one are you using now?  Probably 2.4.17/18-preX is the safest to use,
I never used 2.4.15, so I don't know much about it, and 2.5.1 is certainly
not going to be the most robust kernel.

Cheers, Andreas
Andreas Dilger

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]