[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OOPS: kernel BUG at transaction.c:1857 on 2.4.17 while rm'ing 700mb file on ext3 partition.


On Thu, Jan 24, 2002 at 11:53:27PM +0100, frode wrote:

> >>I got the following error while rm'ing a 700mb file from an ext3 partition:
> >>Assertion failure in journal_unmap_buffer() at transaction.c:1857:
> >>"transaction == journal->j_running_transaction"
> > Hmm --- this is not one I think I've ever seen before.
> OK, I rebooted and gzip'ed the NVdriver in /lib/modules... to make sure the 
> module doesn't load (lsmod now says my kernel isn't tainted). I'll try using the 
> plain 'nv' driver shipped with XFree instead for a while. I tried making another 
> 700mb iso image and fool around with it (loopback mount it, umount it, then rm 
> it) but couldn't trigger anything - but I just spent five minutes trying.

Have you been able to reproduce any problems yet?

> As I mentioned I have had quite a few oopses lately, most of them regarding 
> paging etc. (but I'm no kernel expert). See for example
> http://marc.theaimsgroup.com/?l=linux-kernel&m=101096234600708&w=2
> and
> http://marc.theaimsgroup.com/?l=linux-kernel&m=101128528029736&w=2

iput() crash; page list crash; jbd transaction crash.  These look
perfectly consistent with random memory corruption.
> I'm running linux on an old p100 as well but don't see any problems, so as you 
> say I suspected a hardware problem. I ran MemTest86 for about half an hour 

Try leaving it running overnight --- half an hour is very little time
for a proper memory test.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]