[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ARE: Changing journaling mode on root / loop-aes

Mr. Rugolsky:

	I would have to say that I run "up2date" at least once a week on
the systems I manage, so I wonder why this fix not available via

	Generally I stay away from using rawhide RPMs since they can
have bugs and as I understand it, and is not production level ready.
Thus, it is quite interesting that if there is a fix for this (which is
script based, not code needing recompilation and distribution of new
binaries), why there is no new update available via up2date?

	I will get the most recent mkinitrd from the rawhide
distribution, and see if it fixes the problem.

	Thank you for your time, advice and consideratoin.

Very Respectfully, 

Stuart Blake Tener, IT3 (E-4), USNR-R, N3GWG 
Beverly Hills, California
VTU 1904G (Volunteer Training Unit) 
stuart bh90210 net 
west coast: (310)-358-0202 P.O. Box 16043, Beverly Hills, CA 90209-2043 
east coast: (215)-338-6005 P.O. Box 45859, Philadelphia, PA 19149-5859 

Telecopier: (419)-715-6073 fax to email gateway via www.efax.com (it's


Monday, July 08, 2002 1:04 PM

-----Original Message-----
From: Bill Rugolsky Jr. [mailto:brugolsky telemetry-investments com] 
Sent: Monday, July 08, 2002 12:45 PM
To: Tener, Stuart B., IT3 , USNR-R
Cc: ext3-users redhat com
Subject: Re: Changing journaling mode on root / loop-aes

On Mon, Jul 08, 2002 at 11:40:26AM -0700, Tener, Stuart B., IT3 , USNR-R
> 	(c) I then made sure that /etc/fstab had the "data=journal"
> option in the root partition entry. Then I verified that
> "rootflags=data=journal" was placed in the /etc/grub/grub.conf file
> properly, and rebooted. However, the same result occurred the "03:06"
> boot error...AGAIN!?! ARGH!!!

Sorry to join this party late, but ....

You say elsewhere in this thread that you are using a RH7.3ish system
with an initrd.  But the rootflags=data=journal flag is only for use
when ext3 is compiled into the kernel.  [Someday Rusty Russell will
unify param handling, $DEITY willing.]  When using an initrd with the
ext3 and jbd modules, you need to place the appropriate options in
/etc/fstab, and remake the initrd.  Caveat: the version of mkinitrd
that shipped with RH7.3 does not do this automatically.  In fact, it
was added on 2002/05/21 by Erik Troan:

   * Tue May 21 2002 Erik Troan <ewt redhat com>
   - use options from fstab for root filesystem (56071)

[Courtesy of "rpm -q --changelog mkinitrd" on my box.]

The number in parentheses is the bugzilla number; see

So what you have to do is go to Rawhide and grab a recent mkinitrd,
install it with rpm -Uvh mkinitrd-*.i386.rpm,
then rebuild your initrd.

Something like:

   rpm -Uvh mkinitrd-3.4.12.i386.rpm
   cp /boot/initrd-`uname -r`.img /boot/initrd-`uname -r`.sav
   mkinitrd -v /boot/initrd-`uname -r`.img `uname -r`

and reboot.


   Bill Rugolsky

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]