[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: help - I think partition magic just clobbered me.

"Stephen C. Tweedie" wrote:
> Hi,
> On Fri, May 10, 2002 at 05:48:57AM -0400, Thomas Kerstan wrote:
> > I have(had) redhat 7.2 installed along with win 98.  my
> > latest kernel appeared to be working fine. the /boot and
> > / partition were set up as ext3. I had it running
> > for over a week, before booting back to win 98. while
> > running under win 98 I started partition magic 7.0, which
> > claims to know about ext2 partitions.  It gave me the
> > same error twice, I unfortunate did not note the error
> > at the time. it was something like "CHS and LBA block
> > count do not match. lba is calculated as correct. fix
> > this error" to which I mistakenly said yes.
> >
> > Now I cannot boot linux.  I get kernel panic with all 3
> > kernels I had set up for lilo. prior to the kernel panic
> > the error cramfs: wrong magic. appears.
> Your boot loader configuration has been toasted by the geometry
> rewrite.
> > First question, can someone confirm that this error
> > is in fact caused by whatever partition magic did ?
> Probably, yes.
> > Second question, can it be fixed ?
> Maybe.  The best bet would be to start by booting from a rescue CD and
> seeing if you can at least see the Linux partitions,  Then you'll
> probably need to rerun the lilo or grub install to reset the boot
> loader to something sane.
> Cheers,
>  Stephen

Thanks to steve and steve for their replies.

Here is what happened, Just in case someone else makes the same mistake.
(also FYI, I was not changing anything on this drive when those
partition magic errors occurred, just starting partition magic to check
out another drive) 
My Win98 configuration consisted of multiple partitions. When I
used Redhats' disk druid to allocate the linux partitions, I allocated
them in the middle of the drive (cause I had heard of a windows bug
if the last partition in an extended partition is not a fat partition)
Anyway, the disk druid assigned the new partitions hda8, hda9 and hda10
and left the last vfat as hda7 even though it was a after 8,9 and 10
on the drive.

What partition magic did in its "repair" was to reassign the partition
numbers so that that last vfat partition was now hda10 and what was
8, 9 and 10 were now 7,8 and 9. Since all my lilo configs had root
as hda10, which was now a vfat partition, that's why nothing worked.
So, thanks to a downloaded gpart bootable disk, I was able to see all
this and boot from the install floppy with the command
linuz root=/dev/hda9

all is well again (at least with this computer)

thanks again for the help,

kerstan comcast net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]