[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fsck forced on every system crash

Andreas Dilger wrote:

On May 19, 2002 23:43 -0400, David Chase wrote:

Hi all, I seem to be having a problem whereby my ext3 filesystem forces
a full fsck on every hard system crash.  This takes over 20 minutes on my
40GB drive and is driving me nuts.  I've verified that the partition is,
in fact, being mounted as ext3 and have tried removing ^has_journal and
re-creating the journal file but nothing has worked.  I'm running RH7.2...
Any ideas would be much appreciated.

How did you confirm this? Via "mount" output, or via "cat /proc/mounts"? When e2fsck is run, what reason does it give for running?

Andreas, as soon as I had clicked "send" it occurred to me that I may not have "confirmed" after all. "cat /proc/mounts" output the following:

/dev/root / ext2 rw 0 0

So I assume you're correct -- I'm not mounting as ext3 after all, hence the fsck. Any ideas why the partition is being mounted as ext2? Apologies for asking such a simple question in a very technical mailing list, but I've exhausted the FAQ, the man pages, and several Google searches... Besides, even techies start as newbs :)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]