[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Odd error: Physical size does not match superblock size

Hello, I had something interesting happen on a RH8 ext3 system I setup.I
am at a loss to understand what happened.

This system has two IDE disks, partitioned identically, and the largest
partition on each (/dev/hda3 and /dev/hdb3, 96GB each) was mirrored in a
linux software RAID-1 configuration.
It was running fine for many months. Then I updated the kernel and
needed to reboot accordingly. (2.4.18-14.8.0smp -> 2.4.18-27.8.0smp)

Upon a reboot, fsck complained that /first1 (/dev/hda3)'s superblock or
partition table reported 25712032 blocks, while the physical disk
reported 25712016. (a difference of 16). I tested with new and old
kernel, and the error occured on both.

I tried fsck and e2fsck passes with varied options on /dev/hda3
(/first1) to hopefully fix the problem (it did not). fsck would complain
upon starting that the drive had errors, but never found any and
completed successfully without reporting the errors.
I could then run fsck again, and the error message would repeat, but
nothing would actually be found during the fsck passes.

I also did a badblocks check. (nothing)

I tried several more things. No matter what I tried, I could not fix
this problem. Anybody have a clue as to what I could have done?

Solution I chose:
Since I had the data backed up, I eventually formatted /dev/hda3 and put
a new, clean ext3 fs on it. I then ran resize2fs and decreased the
filesystem by 16 to match what the physical said. Then I rebuilt the
RAID-1 array and the problem went away.

I was hoping there would be a more elegant solution. Anybody have an
idea how this error occured, or what I could have done differently?


Bobbyjoe Glover <glover pa msu edu>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]