[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

fsck fails (then succeeds)


This may be a slightly rambling and inexpert question from
point of view of the learned folks on this list - feel free
to go and read something more interesting, but I am curious
and a little alarmed about a recent event.

I am running Linux from Scratch ("LFS"), under a locally
compiled Kernel 2.4.20 (SMP).  The root filsytem was created
as ext2 and converted to ext3 with an external journal about
9 months ago.  I have ext2fsprogs v.1.33.

Everything has worked perfectly so far, and ext3 has
recovered succesfully from several unauthorised shut-downs. 
I confess that I had given up doing fscks.

Last night I had a system lock-up (graphics card issue I
think), and had to hit the reset.  I noticed that on reboot
(which was successful), I did not see the usual "errors were
found and fixed ... " warning.  I thought I would do a fsck
just to check that all was well.  I ran e2fsck from my old
SuSE 7.0 rescue disk on the unmounted filesystem.  This
produced the "bad superblock / not a valid ext2 filsystem" 
warning.  I rebooted successfully into LFS and then I shut
down "-r -F" to force a check.  The fsck ran and at about
95% complete I got a big red "errors have been found which
cannot be fixed" warning and the system halted "pending
manual intervention" (fat chance).  I rebooted and the
system came up just fine.  I hit the reset button.  This
time I did see the "errors were found and fixed ... "
message. I shut down again "-r -F".  This time the fsck
completed without problems. So, I seem to be back to normal.

Can anyone explain what was going on?

Should I be worried?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]