Ext3 problem - lost files/directorys

bill root pasdebill at hotmail.com
Wed Mar 3 22:24:33 UTC 2004


I work on this harddrive for 3 days now ...
I had noticed errors in kernel while working on a harddrive (120 gigas) but
all continue to work fine (archives/directory)..

So i have unmounted the driver and try e2fsck... bad !

e2fsck 1.34 (25-Jul-2003)
e2fsck: Attempt to read block from filesystem resulted in short read while
trying to open /dev/hdc1

So i have tried to create 1 image of this drive with dd_rhelp and there are
results : 

e2fsck 1.34 (25-Jul-2003)
Group descriptors look bad... trying backup blocks...
Superblock has a bad ext3 journal (inode 8).
Clear<y>? yes

*** ext3 journal has been deleted - filesystem is now ext2 only ***

/hdd1/hdc1.os was not cleanly unmounted, check forced.
Pass 1: Checking inodes, blocks, and sizes
Root inode is not a directory.  Clear<y>? 

I have tried with -b <num> but with same result 
When i re-create then filesystem (with  -S) and e2fsck i have all files in
lost+found (all with <number>, not one file with his real name)

So some questions : 
- There are no way to recover with filename ?
- Where are stored files name / directory's name ?
- why, where i try another superblocks i got same results ?

My last chance are to wait the replacement harddrive, and copy it with DD
But i'm affraid to got same results...

I don't need to recover all files, but the maximum with names (even if files
are not in real directory)

And last question, there are not backup of journal stored like superblocks?
I mean backup stored on harddrive ?

Excuse me for my poor english :) 
Nota : harddrive are a very low count of badblocks, but the actual badblock
seem to be on a very bad place ...

More information about the Ext3-users mailing list