Corrupted journal

Ash my_qa2004 at
Fri Sep 24 14:01:53 UTC 2004

I was running few tests on the Ext3 filesystem having
an external journal; basically trying to check
recovery in crash scenarios.

I started with simple scripts doing some filesystem
operations on the ext3 partition and crashed the
system with a direct poweroff. On reboot, I also
corrupted the journal device by "dd"ing it out with
blocks of zeroes.

Now, when I try to mount the filesystem I get "mount:
wrong fs type, bad option, bad superblock on ..."
which, I guess, is expected also.

After this I tried to run e2fsck (specifying the
journal device with the -j option) and this gives me
"External journal has bad superblock" which is also
understandable since the journal device was also

Next, I tried to clear the journal parameter in hope
of being able to run fsck after that is done. 
But "tune2fs -O ^ has_journal" tells me 
"The needs_recovery flag is set.  Please run e2fsck
before clearing the has_journal flag."

And of course, I can't reset the "needs_recovery" flag

either. So now e2fsck is telling me that the journal
is corrupted and if I try to clear the journal
parameters, tune2fs tells me to run e2fsck first. I
seem to be stuck in this loop.

What can I do to recover my filesystem, clear the
existing journal information and attach a new journal
to the filesystem ?

Any help/pointers will be appreciated.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Ext3-users mailing list