e2fsck errors after lvextend when trying to resize2fs

Stephen Warren swarren at wwwdotorg.org
Mon Feb 7 01:27:13 UTC 2005

Douglas E. Warner wrote:

> I found a thread that has almost the exact same symptoms as me, but didn't 
> seem to come to a resolution:
> https://listman.redhat.com/archives/ext3-users/2004-December/msg00018.html

This was me. My solution:

mkreiserfs /dev/...

Luckily, the only partition of mine that got corrupted was my backup 
partition, so it was trivial to re-create this simply by running my 
backup scripts again after formatting the partition as reiser.

I then converted all my other partitions over to reiser, luckily having 
left enough unpartitioned space on my disk to create some temp 
partitions for use during the conversion.

Whilst there were (I think?) some (potential?) solutions listed in that 
thread, since the issue seemed very complicated, I wasn't convinced that 
it would be solved with a simple update to the FC3 RPMs. I think that 
even if I had stuck with ext3, I would have needed to reformat my 
partitions anyway, so switching fs type was no extra work. I tested out 
reiserfs, and found that resizing worked out of the box without any 
workarounds, and figured that was safer than hopefully remembering to do 
the required workarounds/fixes.

Stephen Warren, Software Engineer, NVIDIA, Fort Collins, CO
swarren at wwwdotorg.org     http://www.wwwdotorg.org/pgp.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
URL: <http://listman.redhat.com/archives/ext3-users/attachments/20050206/49d9e710/attachment.sig>

More information about the Ext3-users mailing list