ext3 compatibility between 2.4 and 2.6 kernels

Howdy Pierce howdy at cardinalpeak.com
Tue Feb 22 00:01:50 UTC 2005


We have a system where a central server formats removable hard disks,
which are then booted in an embedded system running a highly modified
RH9.  The removable disks themselves contain boot, root, and data

The problem we've encountered after upgrading to FC3 / kernel 2.6 on
the central server is that the 2.4 kernel in the embedded system
cannot read the root filesystem, and panics with a message about not
being able to find init.

The scenario is -- running FC3:

  1. "mkfs -t ext3 -O none <device>" on removable disk
  2. "mount -Onoacl,oldalloc,nouser_xattr <device> <mountpoint>"
  3. "tar xf" onto mountpoint
  4. "umount <mountpoint>"

(repeat for each of /boot and / filesystems)

I've tried various combinations of mkfs options and mount options,
with no luck.  

Furthermore, I've tried performing the mkfs on a RH9/kernel 2.4.20
system, and then performing the mount/tar/unmount on a FC3/kernel
2.6.9 system.  Even this combination fails -- it seems the untarring
on FC3 somehow creates an ext3 filesystem that the embedded 2.4 kernel
cannot read.

Finally -- this may be a clue -- I've noticed that regardless of where
the ext3 filesystem was created, symbolic links created on the FC3/2.6
kernel cannot be read on my 2.4 kernel.

Are these known issues?  Is this expected behavior?

Can you recommend anything to fix the problem (aside from upgrading
the embedded kernel to 2.6?)

Thanks for your help,

  Howdy Pierce
  Managing Partner
  Cardinal Peak, LLC


More information about the Ext3-users mailing list