[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: e2fsck errors after lvextend when trying to resize2fs

Douglas E. Warner wrote:

I found a thread that has almost the exact same symptoms as me, but didn't seem to come to a resolution:

This was me. My solution:

mkreiserfs /dev/...

Luckily, the only partition of mine that got corrupted was my backup partition, so it was trivial to re-create this simply by running my backup scripts again after formatting the partition as reiser.

I then converted all my other partitions over to reiser, luckily having left enough unpartitioned space on my disk to create some temp partitions for use during the conversion.

Whilst there were (I think?) some (potential?) solutions listed in that thread, since the issue seemed very complicated, I wasn't convinced that it would be solved with a simple update to the FC3 RPMs. I think that even if I had stuck with ext3, I would have needed to reformat my partitions anyway, so switching fs type was no extra work. I tested out reiserfs, and found that resizing worked out of the box without any workarounds, and figured that was safer than hopefully remembering to do the required workarounds/fixes.

Stephen Warren, Software Engineer, NVIDIA, Fort Collins, CO
swarren wwwdotorg org     http://www.wwwdotorg.org/pgp.html

Attachment: signature.asc
Description: OpenPGP digital signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]