Attempting To Recover, fsck infinite looping on me

John Freer john_freer at
Wed Jan 5 17:50:39 UTC 2005

Hey All,

Thanks so much for the responses.  Here's some more details.


1.  120G ATA133 Drive.  Unclean shutdown during power failure.
2.  XP2200, Via chipset ECS K7S5A Mobo, 1G ram.
3.  Drive broken into 3 partitions, / (hda2), /boot (hda1), and swap
(hda3).  Bulk of the drive is in / (hda2).
4.  on reboot, unable to mount the / partition, boot halted.
5.  on next boot, used e2fsck by booting off of RHFC2 Disk 1 in
"linux rescue" mode. ie: e2fsck -vy /dev/hda2.  Many errors reported,
including a statement that the journal was corrupted and needed to be
removed.  Think it was fsck ver. 1.35.

   +Crunched for about 10 minutes through passes 1A, 1B, 1C, and
started 1D.
   +fsck hangs in the middle of pass 1D, then after approx. 20
seconds hung seems to restart pass 1D.
   +I know it is looping/restarting because in pass 1D I get a list
of 50-150 bad/duplicate blocks at different inodes.  At the bottom of
the list I get "Clone duplicate/bad blocks?"  I then press y and get
another list of blocks/inodes with the same prompt.  Press y again,
repeat, say, 5 times.  after the last 'y', fsck hangs for like 30
seconds and then goes back to the same first list of bad
blocks/inodes.  The bad block/inode numbers match exactly to the
first time through.  
   +I tried answering no manually to the duplication and yes to
delete duplicate.  No difference.  Still loops.

   +I downloaded the source for fsck and looked at pass1D.  Not sure
what/why its looping, though the souce is fairly easy to parse.

   +++I think there may be an error message scrolling off the top of
the screen really fast after I answer 'y' to the prompt, but I can't
see it on the terminal.

SAY, LIKE e2fsck -vy /dev/hda >> /tmp/output.txt ?  How would I
format the syntax?

     I'll be happy to do this and make all the data available if it
would help.

   + I also tried re-running e2fsck with -b 32764 to use another
superblock for rebuilding.  This resulted in the same thing.  It said
the journal was corrupt and that it would be removed.  Then it tried
to fix the drive and the same symptoms came up.

6.  Since I thought this might be a memory problem thing, I also
tried running only after re-enabling the swap partition.  ie: mkswap
/dev/hda3; swapon -a;

   +No difference.

7.  I just ordered a new 200G drive.  I'll probably install FC3 on it
this weekend and then try to recover the data off the 120G drive
then.  But I'd sure like to get this drive back up to recover some

What do you suggest next?


More information about the Ext3-users mailing list