[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Attempting To Recover, fsck infinite looping on me

I cannot, however, get fsck to run fully on /dev/hda2 (the main part
of the drive).  I run it and it goes through the first few recovery
steps (1A, 1B, 1C), and then it comes to the problem.

I had the same problem with debian's e2fsck 1.35 (28-Feb-2004) with a 1 terabyte volume (left it fscking for 1 week, it was still looping). I could still mount the volume however, so I mounted it read-only, and copied all the data on another disk. Some files were corrupted of course, and some of them had a wrong size (like 10 GB or even some TB), so I built an exclusion list when copying the data. After that, I had some checksums of the important files so I could find out which were corrupted and which were not.

I *think* that the problem was, that the volume was full, and fsck needed free space to clone blocks or something like that. I couldn't free up space on the volume however, since when I tried it sometimes caused kernel oopses, sometimes made the volume go read-only, and when it didn't, it didn't free a single block (from du's point of view anyway).

I still have an image of the damaged filesystem here (but I think I will destroy it soon, since 1 TB isn't that cheap, as you can guess).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]