clone RHEL 4 ext3 partition

Andreas Dilger adilger at
Wed Jun 8 05:55:31 UTC 2005

On Jun 08, 2005  15:16 +1000, Matt Smith wrote:
> I'm about to roll out a whole bunch of Redhat
> Enterprise 4 workstations and have run into problems
> cloning from the original.
> Normally I would use ghost (v7.5) because it does a
> nice job when cloning to a different sized
> disk.Unfortunately it comes up with read error 29004.
> Looking around it seems that Symantec don't support
> Fedora Core 3 (with Ghost v.8 - don't know if v.9
> works ???).
> Next option was to use dd.
> This worked fine but when I went to resize the
> partition I noticed that Redhat have removed resize2fs
> from e2fsprogs. 
> After installing the Redhat e2fsprogs
> source rpm (and the newest from sourceforge - i tried
> both) and after compiling the resize2fs binary i got
> an error - "Filesystem has unsupported feature(s)"

Both problems are likely from the same root cause - namely
some strange feature enabled in your filesystem.  

What does "dumpe2fs -h {dev} | grep feature" say about
your filesystem?  AFAIK the latest e2fsprogs should
support all the ext3 features in a released kernel.

Cheers, Andreas
Andreas Dilger
Principal Software Engineer
Cluster File Systems, Inc.

More information about the Ext3-users mailing list