e2fsck not detecting corrupt file?

Jochen Tuchbreiter jt at domainfactory.de
Fri Nov 18 16:03:25 UTC 2005


on my ext3 fs I have a file that I can not modify anymore:

$ who am i
root     pts/0        Nov 18 19:42 (
$ ls -al /mnt/path/usage_200306.html
-rw-r-xrw-  1 50946 nobody 99935 Jul  1  2003 /mnt/path/usage_200306.html
$ rm /mnt/path/usage_200306.html
rm: remove regular file `/mnt/path/usage_200306.html'? y
rm: cannot remove `/mnt/path/usage_200306.html': Operation not permitted
$ chmod a+x /mnt/path/usage_200306.html
chmod: changing permissions of `/mnt/path/usage_200306.html': Operation not

The fs is NOT mounted readonly, I can move around / change other files on
the partition.

However running a full e2fsck -f on the fs does not find any problem.

$ ./e2fsck/e2fsck -f /dev/sdb6
e2fsck 1.38 (30-Jun-2005)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
$ ./e2fsck/e2fsck -V
e2fsck 1.38 (30-Jun-2005)
        Using EXT2FS Library version 1.38, 30-Jun-2005

$ stat /mnt/path/usage_200306.html
  File: `/mnt/path/usage_200306.html'
  Size: 99935           Blocks: 160        IO Block: 4096   regular file
Device: 816h/2070d      Inode: 2149222     Links: 1
Access: (0656/-rw-r-xrw-)  Uid: (50946/ UNKNOWN)   Gid: (   99/  nobody)
Access: 2005-11-19 00:36:35.000000000 +0100
Modify: 2003-07-01 04:55:16.000000000 +0200
Change: 2004-02-14 02:35:36.000000000 +0100

$ uname -a
Linux machine 2.4.29-grsec #10 SMP Mon Jul 4 14:26:46 CEST 2005 i686
Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux

This is not a hard disk problem: dd'ed the whole partition from one disk to
a brand new one and had the same problem on the new disk.

Do you guys have any suggestions on how to further diagnose or fix this? I
also tried it on a 2.6 kernel without grsec, same result.

best regards,

More information about the Ext3-users mailing list