EXT3 filesystem on scsi device becoming readonly

Jayjitkumar Lobhe jayjitkumar.lobhe at patni.com
Mon Aug 28 03:13:10 UTC 2006

Dear All,

Can somebody help me on the following issue:
When I mount the SCSI device on storage with ext3 filesystem & perform cp
in loop, it becomes readonly.

The steps to reproduce the issue are:
1)Create a ext3 file system on HDLM device
      mkfs –t ext3 /dev/sdn
2)Mount the device
      Mount /dev/sddlmaa  /home/<dir. name>
3)Execute cp –f command in a loop on mounted device.
      cp -f /root/install.log  /home/<dir name>/<file name>
4)Disconnect the path. (Either by plugpull or by disabling the port)
5)When all path become offline device will become read-only.
6)Now again connect the path. Though the status of the path becomes
online, device remains as read-only.

The same scenario I tried on ext2 filesystem but it is not reprocible.

I tried this on AS3 Update6.

Please help me on this. Thanks in advance.


More information about the Ext3-users mailing list