[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ext3 fs errors 3T fs

On Thu, 19 Jan 2006, Andreas Dilger wrote:
On Jan 18, 2006  16:16 -0800, Dennis Williams wrote:

I have a ~3T ext3 filesystem on linux software raid that had been behaving
corectly for sometime.  Not to long ago it gave the following error after
trying to mount it:

mount: wrong fs type, bad option, bad superblock on /dev/md0,
       or too many mounted file systems

This sounds like the superblock has been overwritten.  There are occasional
reports from > 2TB filesystem users of similar corruption.  It isn't clear
if the problem exists in ext3 or if it is in the block or SCSI layer.

some more information on the system:
os flavor: Suse 9.1
kernel version: 2.6.5-7.202.7-default (various suse patches applied to
   2.6.5 kernel)

32bit or 64bit?

RHEL4 (2.6.9) claims support for up to 8TB filesystems.  I don't know what
patches they made, if any, in order to have this working.

FWIW, when we first tried using a >2TB filesystem on linux (I think it was FC3 at the time), we discovered filesystem corruption once data had been written past the 2TB mark on a 32-bit machine. I'm guessing this is what you're seeing also.

We have been using (and filling) >2TB filesystems on 64-bit machines (FC4 and RHEL4) for some time now without problems.

Note that we didn't bother doing a detailed analysis of configurations, but rather tried a couple of variations until we found one that worked, so this could be a red herring (for those not familiar with the term, that means a clue that leads you in the wrong direction).

Damian Menscher
-=#| <menscher uiuc edu> www.uiuc.edu/~menscher/ Ofc:(650)253-2757 |#=-
-=#| The above opinions are not necessarily those of my employers. |#=-

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]