[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: EXT3-fs: invalid journal inode.

On Tuesday 26 September 2006 01:09 pm, Sabin Dang wrote:
> Hi Everyone,
> I have a server which has a raid array on /dev/sdb. After a crash I
> tried to mount the array and it failed with:
> mount: wrong fs type, bad option, bad superblock on /dev/sdb,
>         missing codepage or other error

Umm.. there's no superblock (or filesystem) on /dev/sdb.  Filesystems are on 
partitions.. such as /dev/sdb1 or sdb2.  Not the raw device.

> dmesg reports:
> EXT3-fs: invalid journal inode.
> I tried to run e2fsck and it failed (The output can be seen below).
> If anyone has any suggestions on how I can restore the filesystem I
> would greatly appreciate the help.

Ouch.. hope you didn't just hose your own filesystem.

Just to be safe... boot from CD into rescue mode.. and try mounting it the 
PARTITIONS as ext2.  If problems persist, nuke the remaining journal (if any) 
my mounting it as ext2 and/or using fsck.ext2.  Once you get it clean at the 
ext2 level and can cleanly mount it.. recreate the journal with tune2fs -j:
	# tune2fs -j /dev/sdb2 (for example)

Then try rembooting ans see how things go.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]