Problem in e2fsck ? read error in journal inode

Erik Andersen Erik.Andersen at
Fri Jan 5 15:31:09 UTC 2007


I'm experiencing some problems on a harddisk (it has crashed for no known reason),
and in pursuit of getting some of the data out of the disk I'm learning to use the
e2fs progs package.

Origianlly I used version 1.38, but after experiencing segfaults in e2fsck -which now is solved,
I upgraded to 1.39, but now I have hit another problem (on another partition):

The partition was formatted as ext3, and debugfs / dumpfs showed that the feature 'has_journal' was present
(as expected).
The e2fsck command gave the following:

# e2fsck -B4096 -b32768  /dev/hda11
e2fsck 1.39 (29-May-2006)
e2fsck: Attempt to read block from filesystem resulted in short read while checking ext3 journal for /var

So it seemed like a problem in the journal, as I could not find any option to e2fsck to tell
it to skip applying (and reading) the journal, I set the filesystem festure 'has_jounal' off, using debugfs:

# debugfs -b4096 -s32768 -w /dev/hda11
debugfs 1.39 (29-May-2006)
debugfs:   feature -has_journal
Filesystem features: filetype sparse_super
debugfs:   show_super_stats -h
Filesystem volume name:   /var
Last mounted on:          <not available>
Filesystem UUID:          2e8920a2-0460-4a87-b729-af812327fce7
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      filetype sparse_super
Default mount options:    (none)
Filesystem state:         not clean
Errors behavior:          Continue

Now trying e2fsck again did not make any difference:

# e2fsck -B4096 -b32768 -y /dev/hda11
e2fsck 1.39 (29-May-2006)
e2fsck: Attempt to read block from filesystem resulted in short read while checking ext3 journal for /var

I also tried to get tune2fs to turn off the journalling, but got the response:

 First turn 'has_journal' back using debugfs:

# debugfs -b4096 -s32768 -w /dev/hda11
debugfs 1.39 (29-May-2006)
debugfs:  feature has_journal
Filesystem features: has_journal filetype sparse_super
debugfs:  quit

 Then use tune2fs:

# tune2fs -O ^has_journal  /dev/hda11
tune2fs 1.39 (29-May-2006)
tune2fs: Attempt to read block from filesystem resulted in short read while reading journal inode

So my questios are:
1) How can I make e2fsck skip reading a faulty journal (in my case there might be a HW error on the block) ?
2) What makes e2fsck act on a journal (is it because journal inode is set) ?
3) Shouldn't e2fsck act on wether the filesystem features (and in case of no 'has_journal' just ignore
   any journal information - of course it still need to make sure the inode used for the journal isn't
   used by anybody else) ?
It was a bit long, if you need any more info - please let me know
One problem is that I have problems reading the raw partition 'dev/hda11' - I tried
to 'dd' it but it failed...


Erik Haukjær Andersen
This e-mail and any attachments are confidential and may also be legally
privileged and/or copyright material of Intec Telecom Systems PLC (or its
affiliated companies). If you are not an intended or authorised recipient
of this e-mail or have received it in error, please delete it immediately
and notify the sender by e-mail. In such a case, reading, reproducing,
printing or further dissemination of this e-mail or its contents is strictly
prohibited and may be unlawful.
Intec Telecom Systems PLC does not represent or warrant that an attachment
hereto is free from computer viruses or other defects. The opinions
expressed in this e-mail and any attachments may be those of the author and
are not necessarily those of Intec Telecom Systems PLC.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ext3-users mailing list