Can't mount /home anymore

Nickel Cadmium nicdnicd at
Wed Jan 10 09:43:48 UTC 2007


I'm new to the list. I have a problem with mounting my home directory since
my PC crashed. I hope that I can get some help on this list as I don't know
much of ext3 myself.

The mount command for my /home gives me the following output:

# mount /dev/sda6 /mnt/tmp/
mount: wrong fs type, bad option, bad superblock on /dev/sda6,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

The partition /dev/sda6 is an ext3 file system. It also tried to specify the
file system type with -text3 and to use a backup superblock with the sb
option but it does not help.

I tried to run fsck but it does not fix the problem either. Here is the
output of fsck:

# fsck.ext3 /dev/sda6
e2fsck 1.39 (29-May-2006)
Group descriptors look bad... trying backup blocks...
Inode bitmap for group 522 is not in group. (block 3271884801)
Relocate<y>? yes

fsck.ext3: e2fsck_read_bitmaps: illegal bitmap block(s) for /home

I searched the Internet and I found a small Windows application that could
see my /home partition and files. So I can't beleive there is nothing under
Linux to recover my files.
I'll appreciate any help on this topic because I tried anything I could
think of by myself and I still can't mount my home.
Any suggestions?

Best wishes!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ext3-users mailing list