Crashed ext3-filesystem

Jürgen Landsmann lanzi at
Thu Jun 7 16:56:23 UTC 2007


We have a server still running Debian 3.0 (Woody) that nobody likes to 
touch for maintenance ... ;)

Our home-directories are located on a separate HDD (30GB, 1 large 
primary ext3 partition) and until yesterday it worked correctly. Because 
the partition was nearly full we had to enlarge our home-space by moving 
it to a larger HDD.

We decided to try a copy of whole partition by using gparted from the 
"SystemRescueCd" (

The first try failed, because the FS-type of our home-partition wasn't 

A second boot was tried and this time the FS-type was recognized 
correctly so we started copying the partition to another HDD (80GB).

After about 40% to 50% the copy-procedure crashed an left our system in 
an unusable state. The only way to re-use the sytem was to press the 

Because we thought that the reason of this crash was caused by an error 
in the APM-funcionality we tried it once more by booting the kernel 
using the "noapm" parameter. But even this try crashed ...

After we rebooted again I mounted the source-partition to check it's 
content. But all I found were three files visible on the partition.

The directory containing the userfiles was completely gone an in 
"lost&found" there are hundreds of items.

After this horrifying discovery I unmounted the partition and subscribed 
this mailing-list ... ;)

Unfortunately also our whole webserver-files were located in this 
directory ...

Now my question:

Is there any possibility to restore my directory (completely or at least 

Thanx in advance for your help!!!


More information about the Ext3-users mailing list