Crashed ext3-filesystem

Jürgen Landsmann lanzi at
Fri Jun 15 09:08:55 UTC 2007

Christian Kujau schrieb:
> On Thu, 7 Jun 2007, Jürgen Landsmann wrote:
>> Our home-directories are located on a separate HDD (30GB, 1 large 
>> primary ext3 partition) and until yesterday it worked correctly.
> ...30 GB and no backups?
plz don't ask, why! ;)

>> Because the partition was nearly full we had to enlarge our home-space 
>> by moving it to a larger HDD.
>> We decided to try a copy of whole partition by using gparted from the 
>> "SystemRescueCd" (
> Why would you do this? What's wrong with tar/cp?
It was just a try and the crashed partition wasn't event mountet. The
partition must have had an unrecognized error!

>  - e2undel, recover (both available as debian packages in unstable)
>  - R-Linux, a free (as in beer) recovery tool for win32 (works pretty 
> good though)
>  - ...and then there's always grep(1) & friends :(
Some items listed there with the type "file" are directories and others
listed as "directory" are files.

I already tried to find some files by using grep, find, cat (...) but no

I will try some of the utilities mentioned above but I don't think,
there is any possibility to get some data back ...

Thanx for your hints!!

J. Landsmann

More information about the Ext3-users mailing list