Solution to Corrupt >2TB Filesystem in MSDOS Partition Table

Jon Forrest jlforrest at
Wed Mar 14 21:07:55 UTC 2007

Thanks to Ted and several others, I was
able to recover 100% of the corrupted
file system that I posted about last week.
(This was an >2TB ext3 file system that had been
created in a MSDOS partition which had worked
until the server was rebooted, at which time
it wouldn't mount and fsck wouldn't fix the

Based on the suggestions of various people
here's what I did:

1) Upgraded to the latest version of GNU parted.
The server is running Scientific Linux 4.3,
a RHEL4 derived distribution with a 2.6.9
kernel. This distribution contained parted 1.6.19
whereas the latest release was 1.8.2.

2) Using parted 1.8.2, I removed the partition
containing the corrupt file system. This was
the only partition on the disk.

3) I then used the parted "rescue" command
to recreate the partition. I gave it the original
starting point at the start value and "-1s" as
the ending value.

After this, I was able to mount the file system as before,
and all the files were there. The first thing I did
was to copy the whole file system to another disk
which completed without any errors.

I have to admit that I don't fully understand why this
worked. Clearly the combination of removing the partition
and then rescuing it reset something that was fouling
up the works before.

Anyway, we're all very happy about this and we all appreciate
the help we received from this list and elsewhere. I hope
we'll be able to help you one day.


Jon Forrest
Unix Computing Support
College of Chemistry
173 Tan Hall
University of California Berkeley
Berkeley, CA
jlforrest at

More information about the Ext3-users mailing list