Bad magic number in super-block

Nickel Cadmium nicdnicd at
Tue Oct 2 21:27:52 UTC 2007


After a power failure, I can't mount one of my partitions anymore. Here is
what I get from fsck:

fsck.ext3 /dev/sdb1
e2fsck 1.39 (29-May-2006)
Couldn't find ext2 superblock, trying backup blocks...
fsck.ext3: Bad magic number in super-block while trying to open /dev/sdb1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

I tried to give the suggested superblock as parameter but I get the same
error message. And with dumpe2fs and tune2fs as well.
Since I can't get the backup-superblock positions with dumpe2fs, I used a
block size of 1K and tried all the supposed-to-be backup superblocks but it
does not help.

Is there anything I can try to mount the partition again?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ext3-users mailing list