Solution to Corrupt >2TB Filesystem in MSDOS Partition Table

rjcarr rjcarr at
Tue Oct 23 22:30:12 UTC 2007

Jon Forrest-2 wrote:
> Thanks to Ted and several others, I was
> able to recover 100% of the corrupted
> file system that I posted about last week.
> (This was an >2TB ext3 file system that had been
> created in a MSDOS partition which had worked
> until the server was rebooted, at which time
> it wouldn't mount and fsck wouldn't fix the
> problem.)

I just wanted to add that I had the same exact situation and this solution
also worked for me.  My only difference was my filesystem was xfs (not
ext3), also, in this part:

> 3) I then used the parted "rescue" command
> to recreate the partition. I gave it the original
> starting point at the start value and "-1s" as
> the ending value.

I knew the exact end value from when I created the partition, so I used it
instead of -1.  Not sure if it would have worked it out had I used -1, but I
thought my number safer.
View this message in context:
Sent from the Ext3 - User mailing list archive at

More information about the Ext3-users mailing list