[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Bad magic number in super-block


Tom, thanks a lot: you solved my problem!

With fdisk -l I discovered that the partition I was trying to mount was a Windows partition. The weird thing is that /dev/sdb1 used to be a Linux partition. Thinking of it again, I had to pull apart my computer after the crash and I probably shuffled the disks around (or could the renumbering / device reassignement occur even without hardware change?).
But in short, the partition I was looking for is now in /dev/sdc1 and updating the partition table solved it all.

Thanks & cheers,

On 10/3/07, Thomas Watt <tango tiac net> wrote:
Hi Nickel Cadmium,

First, try running the command (as root): fdisk -l

That should confirm whether /dev/sdb1 is a valid filesystem partition and not a
swap partition.  Look for an ID of 83 which identifies valid filesystem partitions.  A partition with ID of 82 is usually swap and won't have a superblock.

That said, if /dev/sdb1 is not a valid filesystem partition, then choose one
that with an ID of 83 and looks like it has the majority of space.  Then you
should be able to use: dumpe2fs -h /dev/sdb2, for example, and see if you get
any other errors or can then successfully mount the partition.

Sometimes after a reboot, the fdisk -l command reports partitions not in
partition table order and will assign different partition names than the ones
you may normally see to the disk/partition of interest.

-- Tom

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]