wipe freespace on ext3?

Forest Bond forest at alittletooquiet.net
Sat Apr 12 15:36:14 UTC 2008


On Sat, Apr 12, 2008 at 04:09:17AM -0700, defcon wrote:
> Hey all, I have failed at wiping my freespace on my hard drive, what I
> have done is:
> [dd] if=/dev/urandom of=bigfile
> and I also have tried sfill from the secure delete package from thc.
> I have successfully recovered all deleted files after wiping the hard
> drive with foremost, since this is a journaling filesystem is there
> any way around this, is anyone experienced in this and have tried to
> wipe/recover files on ext3?

If you wiped so little data that the kernel cached it all and you removed
bigfile before the cache could be flushed, perhaps the disk never got touched.
Maybe try `sync' after running dd.

Forest Bond
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <http://listman.redhat.com/archives/ext3-users/attachments/20080412/fa6ffddd/attachment.sig>

More information about the Ext3-users mailing list