problems with ext3 after resizing

Massimo Bongi massimo.bongi at
Wed Feb 13 11:02:05 UTC 2008

I have problems with an ext3 partition whose data I would like not to
lose, and I hope some one can help me..

I've used parted 1.6.19 to grow an ext3 partition (after adding some
disks to a RAID array). It worked without errors, but now when I try
to mount again the partition I get:

# mount -t ext3 /dev/sdb1 /mountpoint
mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       or too many mounted file systems

with a corresponding message in dmesg:

EXT3-fs: journal inode is deleted.

I also tried mounting it ext2, getting the same from mount and this in dmesg:

EXT2-fs: corrupt root inode, run e2fsck

If I try dumpe2fs it does not complain:

# dumpe2fs -h /dev/sdb1
dumpe2fs 1.35 (28-Feb-2004)
Filesystem volume name:   <none>
Last mounted on:          <not available>
Filesystem UUID:          bf311738-c5af-4642-81ee-5fe1b2a4921f
Filesystem magic number:  0xEF53
Filesystem revision #:    1 (dynamic)
Filesystem features:      has_journal filetype sparse_super large_file
Default mount options:    (none)
Filesystem state:         clean
Errors behavior:          Continue
Filesystem OS type:       Linux
Inode count:              851853312
Block count:              1703705079
Reserved block count:     0
Free blocks:              1413636793
Free inodes:              851801401
First block:              0
Block size:               4096
Fragment size:            4096
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         16384
Inode blocks per group:   512
Last mount time:          Mon Feb 11 10:01:29 2008
Last write time:          Mon Feb 11 10:03:16 2008
Mount count:              13
Maximum mount count:      30
Last checked:             Fri Nov 30 11:58:05 2007
Check interval:           0 (<none>)
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               128
Journal inode:            8
Journal backup:           inode blocks

and actually a plain e2fsck says it is clean. To make ireally t check
the partition I added -f, and in this case I get:

# e2fsck -f -n /dev/sdb1
e2fsck 1.35 (28-Feb-2004)
Pass 1: Checking inodes, blocks, and sizes
Root inode is not a directory.  Clear? no

Journal is not regular file.  Fix? no

Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Root inode not allocated.  Allocate? no

Cannot proceed without a root inode.
e2fsck: aborted

Does anyone understand what's going on? Which is the best strategy to
recover it? I fear that a e2fsck -f without will delete the root inode
and I will lose everything..

Any help is appreciated,

More information about the Ext3-users mailing list