needs help, root inode gone after usb bus reset on sata disks

Jelle de Jong jelledejong at
Thu May 29 20:15:08 UTC 2008

Theodore Tso wrote:
> On Thu, May 29, 2008 at 04:44:08PM +0200, Jelle de Jong wrote:
>> Ok, this did not when so great...
>> e2fsck -nf /dev/sda1 > e2fsck-nf-info-sda1.txt 2>&1
>> e2fsck -fy /dev/sda1 > e2fsck-fy-info-sda1.txt 2>&1
> OK, this makes no sense whatsoever.  In the first pass, it complained
> about the root inode being corrupted; that's fine, that was probably
> from the initial hardware corruption.
> The second time you ran e2fsck, it didn't complain about anything
> until pass #5, so apparently the root inode was OK the second time
> around.  But when you run e2fsck with -n, it opens the device
> read-only, so theres no way the filesystem could have changed.
> If you didn't run any other commands or do anything else between the
> two runs of e2fsck, then you have some serious hardware problem where
> the disk is not returning the same data between the first and second
> e2fsck run.  And if you have wierd hardware problems, either with the
> hard drive or how the hard drive is connected to the OS, there's
> really nothing e2fsck can do to help you.....

no no, i think i did not give enough info sorry :-p

I did the following:

debugfs -w /dev/sda1
debugfs: features dir_index filetype sparse_super
debugfs: quit

then i run

e2fsck -nf /dev/sda1

to see if it still wanted to relocate inodes. This was not the case 
anymore, however it still wanted to relocate the root inode...

I then run:

e2fsck -f /dev/sda1

and manual answer yes to the question until i had to enter a lot of "y" 
(see logs) and killed the program with ctrl-c

then i run the following commands:

e2fsck -nf /dev/sda1 > e2fsck-nf-info-sda1.txt 2>&1
e2fsck -fy /dev/sda1 > e2fsck-fy-info-sda1.txt 2>&1

I am now restoring the backup so i we can try again....

Hope things make more sens now.



More information about the Ext3-users mailing list