ext3_free_blocks_sb when removing a more than 1GB file

Eric Sandeen sandeen at redhat.com
Fri Mar 4 17:59:08 UTC 2011

On 3/4/11 11:54 AM, Stephane Cerveau wrote:
> Hi,
> Thanks for your answer.
> Here is my steps:
> - mkfs.ext3 /dev/sda1
> - mount /dev/sda1 /mnt/usb
> - dd if=/dev/zero of=/mnt/usb/test_file bs=1M count=1025   ( the size is important)
> - sync
> - rm /mnt/usb/test_file

Ok, I had the impression that you were removing the usb key at
some point in the test, but I guess not.

> Then many errors appears "Ext3-fs error ( device sda1): ext3_free_blocks_sb: bit already cleared for block xxxx"
> I tried to umount/mount the storage but its not working also.
> I tried to check the device before removing the file, not working also.

you mean that umount/mount/rm gives the same error?  As does umount/fsck/mount/rm ?

> Indeed with another usb key it's working...
> I'm using a kernel 2.6.23
> The problem does NOT appear with mkfs.ext2 /dev/sda1 before
> What do you advise to do ?

Try a much newer kernel, first of all, to see if it's a known, fixed bug.

But since it works on another usb key, I still tend to blame the hardware.
"bit already cleared" makes it sound like it is reading zeros when it
should not be.

> BR
> Stephane.

More information about the Ext3-users mailing list