ext3_free_blocks_sb when removing a more than 1GB file

Stephane Cerveau scerveau at awox.com
Sat Mar 5 15:52:50 UTC 2011

Hello Alex,

With a brand new key, I had the issue after formatting it, copying the file and erasing the file without any shutdown or any trouble...

I will have a look into the commit you stipulated in your email and let you know ...

De : Alex Bligh [alex at alex.org.uk]
Date d'envoi : samedi 5 mars 2011 10:21
À : Stephane Cerveau; Eric Sandeen
Cc : ext3-users at redhat.com; Tristan Pateloup; Alex Bligh
Objet : RE: ext3_free_blocks_sb when removing a more than 1GB file

--On 4 March 2011 18:54:23 +0100 Stephane Cerveau <scerveau at awox.com> wrote:

> Then many errors appears "Ext3-fs error ( device sda1):
> ext3_free_blocks_sb: bit already cleared for block xxxx"
> I tried to umount/mount the storage but its not working also.
> I tried to check the device before removing the file, not working also.
> Indeed with another usb key it's working...
> I'm using a kernel 2.6.23

If it's that old, perhaps it is
fixed by
in 2.6.29
 commit 7ef0d7377cb287e08f3ae94cebc919448e1f5dff
I think.

I am interested in this particular error. We see it very occasionally
on 2.6.31 in an environment where we can be sure no underlying I/O
error occurred (because it's on a VM whose dom0 uses iSCSI mapped
to the domU's disk) and we would see error logging. It is normally
during intense disk activity (unlike the OP), such as running
"aptitude update", often while unlinking a file. It does not
appear to happen on ext4. Unfortunately the result is that the disk
goes readonly. Our current theory is that the disk got
damaged in some way during a previous unclean shutdown that fsck
did not fix. Is that possible?

Alex Bligh

More information about the Ext3-users mailing list