[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

What uses these 50 GB?



Hello everybody,

first of all thank you the development of Ext2/3/4. It works like a charm and makes it possible to base applications on it.

However, now I have the first time where I need more information to understand the behaviour of a ext4 installation on a 480 GB harddisk.
It holds a database with a size of 355 GB, as said by

"du -m":

...
355263  /opt/ssd

However, "df" says:

Filesystem      1K-blocks       Used Available Use% Mounted on
...
/dev/sdc        468346644  409888536  35015532  93% /opt/ssd

I do understand why there is a gap between "Used" plus "Available" and "1K-blocks", but I don't understand why "Used" is so much bigger (54 GB difference) than what "du -m" indicates.

I can rule out any issues with inodes; "df -i" indicates that less than one percent is used.

I tried to understand more details by using "debugfs". I thought I get a full list of used blocks with:

for i in *; do { echo "blocks $i" | sudo debugfs /dev/sdc | grep -vE "^debugfs" | awk '{ for (i=1; i < NF; ++i) print $i; }'; }; done

which delivered 90938943 lines (containing block numbers allocated by visible files). But

echo "testb 1 117330000" | sudo debugfs /dev/sdc | grep "marked in use"

has delivered 102595007 lines (containing block numbers marked as "used").

I tried to learn more about blocks marked as "marked in use" but not by a known file, and

echo "icheck 98304 98305" | sudo debugfs /dev/sdc

returned

debugfs:  icheck 98304 98305
Block   Inode number
98304   <block not found>
98305   <block not found>

Could somebody explain to be what the purpose of these 11,656,064 blocks is that don't belong to an inode but are still marked as used?

Do I have a chance other than reformatting the drive to get back this space?

Best regards,

Roland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]