[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: polkit-gnome-authorization missing



On 10/20/2009 03:10 PM, Matthias Clasen wrote:
On Sun, 2009-10-18 at 13:55 +0200, Jeroen van Meeuwen wrote:
I would put it in
/var/lib/polkit-1/localauthority/20-org.d/10-packagekit-policy.conf.

That should
be /var/lib/polkit-1/localauthority/20-org.d/10-packagekit-policy.pkla,
I think.


OK, fair enough

What is "any subject"? Both Active and Inactive? Then why not require
both to be set and eliminate this variable? Is anything other then
Active and Inactive included in Any?

If you read the small print, ResultActive/Inactive are described as
applying to subjects in _local_ sessions. Presumably, ResultAny covers
subjects in remote sessions (or even without sessions ?) as well.


Maybe such can be clarified especially for first time users.

What does Require* have to do with Result* exactly?

This is a bug, I would say. The paragraph is supposed to refer to
ResultFoo, not RequireFoo. I've reported it here for you:
https://bugs.freedesktop.org/show_bug.cgi?id=24640


Thanks!


[1] $ polkit-config-file-validate ~/tmp/10-packagekit-policy.conf
polkit-config-file-validate: error while loading shared libraries:

You really should not have polkit-config-file-validate installed. It is
part of the PolicyKit 0.9 packages that have been obsoleted by polkit.


Is there a way to verify whether my configuration files make any sense to polkit? I tend to do stuff beyond what is acceptable by the application using the config file every once in a while ;-)

Thanks,

Kind regards,

Jeroen van Meeuwen
-kanarip


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]