[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

[fedora-java] The default java alternative?



Hello,
  I noticed that "BuildRequire: java-devel" is interpreted
differently on different architectures.  Namely, it evaluates
java-1.5.0-gcj-devel on ppc{,64} and x86_64 but to
java-1.6.0-openjdk-devel on i586.
I observed this in rawhide koji.

This inconsistency brings various problems, like totally different
documentations builds between i586 and x86_64 (javadoc vs. sinjdoc)
or arch-dependent bugs, e.g., jni.h not found on i586 (#498964).

What's the intended default and who is the guilty one here?

Regards,
	Stepan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]