[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Warren's Package Naming Proposal - Revision 1



On Fri, 2003-10-31 at 07:55, Ville Skyttä wrote:
> On Fri, 2003-10-31 at 19:00, Michael Schwendt wrote:
> > On Fri, 31 Oct 2003 04:31:09 -1000, Warren Togami wrote:
> > > 
> > > Err... you are completely right about it not being necessary in the 
> > > post-release case.  I am not sure why our fedora.us policy retained that 
> > > even though it was unnecessary for all these months.  The way I 
> > > understand the older version of rpm broken rpmvercmp behavior, this 
> > > wouldn't be a problem with those versions too.
> > 
> > * To be able to go back from 2.1.7a to a patched 2.1.7 in case the
> >   2.1.7a post-release "fix" turns out to cause side-effects.
> > 
> > * Consistency above all.
> > 
> > * The road of least surprise (with regard to upstream versioning).
> > 
> > * To help avoid that users think foo-1.0a would be an unstable alpha
> >   version, when in fact it is a post-release patch-level.
> 
> Also, if foo-1.0a < foo-1.0b < foo-1.0a, as presented earlier in the
> proposal (the "two-way upgrade problem") exists for prereleases, why
> wouldn't it exist for postreleases?

Actually, the two-way upgrade problem was fixed right before RH9.  So
rpm-4.2 in RH9, rpm-4.2.1, rpm-4.1.1, rpm-4.0.5 all behave properly in
this case.

This however does not matter, since it has been agreed upon on
fedora-legacy list that ALL distributions supported by Fedora Legacy
will force an upgrade of rpm as a requirement for users to begin using
those repositories.  This is in order to enforce consistency and avoid
old bugs that were fixed ages ago.  (A tremendous amount of verification
testing will happen before each rpm is published for Legacy.)

Warren




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]